Group syn_crypto¶
SHA256, ChaCha20Poly1305, Curve25519, and Blake2s primitives.
Files¶
| Type | Name |
|---|---|
| file | syn_aes.h Unified AES cipher engine (128/192/256-bit keys, ECB, CBC, CTR, and GCM AEAD). |
| file | syn_aes_cmac.h AES-CMAC (Cipher-based Message Authentication Code, RFC 4493 / NIST SP 800-38B). |
| file | syn_asn1.h Zero-Heap ASN.1 DER (Distinguished Encoding Rules) TLV Parser. |
| file | syn_blake2s.h BLAKE2s cryptographic hash — RFC 7693, pure C99. |
| file | syn_chacha20poly1305.h ChaCha20-Poly1305 AEAD — RFC 8439, pure C99. |
| file | syn_ed25519.h Pure C99 Ed25519 Key Generation, Signing & Verification (RFC 8032). |
| file | syn_hkdf.h HMAC-based Extract-and-Expand Key Derivation Function (HKDF-SHA256, RFC 5869) & TLS 1.3 HKDF-Expand-Label. |
| file | syn_hmac.h HMAC-SHA256 — keyed-hash message authentication code. |
| file | syn_hmac_drbg.h NIST SP 800-90A HMAC-DRBG (Deterministic Random Bit Generator) with SHA-256. |
| file | syn_p256.h NIST P-256 (secp256r1 / prime256v1) Elliptic Curve Cryptography. |
| file | syn_port_aes.h AES / GCM hardware acceleration port interface. |
| file | syn_sha256.h SHA-256 cryptographic hash — pure C99, zero dependencies. |
| file | syn_sha512.c SHA-512 & SHA-384 cryptographic hash and HMAC implementation. |
| file | syn_sha512.h SHA-512 & SHA-384 cryptographic hash and HMAC — pure C99, zero dependencies. |
| file | syn_tpm2.h TCG TPM 2.0 Command Marshaller, Measured Boot, & Hardware Root-of-Trust Engine. |
| file | syn_x25519.h X25519 Diffie-Hellman key exchange — RFC 7748, pure C99. |
| file | syn_x509.h Zero-Heap X.509 v3 Certificate & Chain Parser and Validator. |