Skip to content

Group syn_net

Modules > syn_net

Packet router, transports, DNS, HTTP, WebSocket, CoAP, and MQTT protocols.

Files

Type Name
file syn_coap.h
Constrained Application Protocol (CoAP - RFC 7252) implementation.
file syn_dns.h
UDP DNS resolver and mDNS responder.
file syn_dnssd.h
DNS-Based Service Discovery (DNS-SD - RFC 6763 / RFC 6762).
file syn_dtls.c
Native Zero-Heap DTLS 1.3 Datagram Protocol Engine (RFC 9147).
file syn_dtls.h
Native Zero-Heap DTLS 1.3 Datagram Protocol Engine (RFC 9147).
file syn_heartbeat.h
Heartbeat / keep-alive monitor.
file syn_http.h
Cooperative HTTP/1.1 client — streaming, zero-alloc, non-blocking.
file syn_httpd.h
Minimal HTTP/1.1 server — route-based, zero-alloc.
file syn_mqtt.h
Lightweight MQTT 3.1.1 client.
file syn_netbuf.h
Zero-Copy Packet Buffer Pool.
file syn_ntp_server.c
Zero-Heap NTP v4 Server Implementation.
file syn_ntp_server.h
Zero-Heap NTP v4 Server Protocol Engine over UDP port 123.
file syn_router.h
Packet router — addressed message dispatch.
file syn_sntp.h
SNTP client — lightweight time synchronization over UDP.
file syn_tcp.h
Zero-Alloc Native TCP State Machine & Segment Engine.
file syn_tls.h
Native Zero-Heap TLS 1.3 Protocol Engine & Transport Adapter (RFC 8446).
file syn_transport.h
Transport abstraction — pluggable send/receive (header-only).
file syn_transport_tcp.h
Bridge for syn_transport over a TCP socket.
file syn_transport_udp.c
Bridge implementation connecting syn_port_udp_* to native syn_udp stack.
file syn_transport_udp.h
Bridge binding syn_port_udp_* API to native syn_udp stack.
file syn_transport_usb_cdc.c
USB CDC Transport Binding Implementation.
file syn_transport_usb_cdc.h
USB CDC Transport Binding Header.
file syn_transport_usb_host_cdc.h
USB Host CDC Transport Binding Header.
file syn_udp.c
Zero-Alloc Native UDP Demuxing Engine & Task-Blocking Layer Implementation.
file syn_udp.h
Zero-Alloc Native UDP Demuxing Engine & Task-Blocking Layer.
file syn_websocket.h
WebSocket protocol support on httpd.
file syn_wg.h
WireGuard VPN client — Noise IK, pure C99, cooperative.